for iPad (v2.7.2.0)

Download from here

 

Splashtop Personal- Remote Desktop:

  • Requires iOS 5.0 or later. Compatible with iPad.
  • Wi-Fi connection
Have more questions? Submit a request

0 Comments

Article is closed for comments.