About Mac OS 10.6 support

Due to recent Xcode update (to Xcode 6.1), to make sure we could roll in more new and innovative features, Snow Leopard Mac OS 10.6 will no longer be supported to install Splashtop client and Streamer; which means, users will not be able to establish remote connections with those Macs still running Mac OS 10.6 using Splashtop Business v2.6.5.2, Splashtop Personal v2.6.4.1 and Streamer v2.6.2.7, or later version.

We recommend that you could upgrade Mac OS 10.6 to Yosemite, you are able to do it for free in some cases (http://www.apple.com/osx/how-to-upgrade/). If for some reason, you still have to stay with Mac OS 10.6, we also provide the last Mac OS 10.6 supported version Splashtop Business and Streamer here, they are:

Sorry for any inconvenience caused, and please leave your comment here or file a ticket if there is any question.

 

Have more questions? Submit a request

36 Comments

  • 0
    Avatar
    Susarayam
    I love u
  • 0
    Avatar
    Lovecool
    It don't work yaal buts
  • 0
    Avatar
    Dualspeed

    This version is great!  It seems the limited resolution has been fixed.  I can now remote in to my 27" iMac from my windows computer and have the resolution resize correctly to match the entire display.  Thank you 

  • 0
    Avatar
    Program22

    Ok, but don't forget - all macs produced before 2008 has EFI32 (not EFI64) and unable to install mac os 10.8, 10.9 and 10.10 (only Lion, Snow L., Leopard).

  • 0
    Avatar
    Baldurthegood

    I am skipping this update. I'm sick to death of defective-by-design mac products. It is unethical and I have no idea why I expected more from them. As updates continue to push my older, but totally fine hardware off the map I will happily move to linux and never do business with Apple again. Good Day!

  • 0
    Avatar
    Ratchetfreaker

    apple is stupid anyway

  • 0
    Avatar
    Teella

    I double it's all apples fault. There is always away around things, especially since OSX is based on *nix and the developers have full access to all the C APIs. This sounds more like a company decision then technical one. Splashtop probably decided it's not worth their time to maintain older OSX ports, due to the small community.

  • 0
    Avatar
    Yousif.Kh84
    Yousif
  • 0
    Avatar
    Yousif.Kh84
    Salim
  • 0
    Avatar
    Unomar

    I run Mac OSX 10.6.8 and have installed Splashtop Personal 2.6.0.0 and Splashtop Streamer 2.6.2.3.

    Can I Can I install Splashtop Personal 2.6.2.1 or shall I keep v2.6.0.0?

    /Uno

  • 0
    Avatar
    Sofiamachado77
    You should make it for the iPhone or iPod like if u use your tablet and lost your iPod you could use it on the tablet and play games that are from the apple
  • 0
    Avatar
    Sofiamachado77
    Answer me back if u could
  • 0
    Avatar
    Mehdi0225
    Hhhh c'Mehdi
  • 0
    Avatar
    Laura_786
    Don't work won't download on my iPad 1 or my iPhone 4s plz fix ;((
  • 0
    Avatar
    Laura_786
    I've paid for the splashtop and it ain't download it dam it u fix it whats sense of sayin u can use it from ur phone when it ain't doin anything daaaah
  • 0
    Avatar
    Vans.Huang

    @Uno,

    There is no compatibility issue running Splashtop Personal app on Mac, it should work.

    @Sofiamachado77,

    We are not sure, does it mean Streamer for iPhone? We have no plan supporing establish a remote session to handset devices like iOS or Android devices at this moment.

    @Laura_786,

    Streamer should be installed on the computer (PC or Mac) you want to remotely control from your iPhone. You can not install Streamer on an iOS device.

  • 0
    Avatar
    Phlaiphearet
    Ilove
  • 0
    Avatar
    Agr

    Would have been nice to know this before buying the App ;-)

  • 0
    Avatar
    Adel--81
    Adtrgaa
  • 0
    Avatar
    Daviddavidsack
    Esta bien
  • 0
    Avatar
    Jamconn1979
    Splash top
  • 0
    Avatar
    Jamconn1979
    Win 8.1
  • 0
    Avatar
    Vans.Huang

    @Jamconn1979, Daviddavidsack, Adel--81 and Adel--81,

    Please let me know if there is any issue you saw. I will delete your comments if they are just spams.

  • 0
    Avatar
    Myfakenamegoeshere

    a yo i need help b! i have paid version for droid g5 and running 10.6 cant upgrade yo. which 1 do i use, kid?

  • 0
    Avatar
    Vans.Huang

    @Myfakenamegoeshere,

    I am not sure about the issue you encountered, but you have to use 2.6.2.3 or older version of streamer on a Mac 10.6 machine to make it work.

  • 0
    Avatar
    Myfakenamegoeshere

    ok.....if im not on my home network and i want to access my mac which is home while i am at a friends home, how do i do it?

  • 0
    Avatar
    Vans.Huang

    @Myfakenamegoeshere,

    Install Splashtop Personal app on your device, install the streamer on your friend's computer, and subscribe AAP, then you will be able to find the computer using Splashtop Personal app and establish remote connections.

  • 0
    Avatar
    Ghorayed20
    👌🏻
  • 0
    Avatar
    Ncruzaddcom
  • 0
    Avatar
    Vans.Huang

    @Ghorayed20 & Ncruzaddcom,

    Did you encounter any issue using Mac streamer?

Please sign in to leave a comment.