Some known issues on Mac Streamer, and work-arounds

I. For Mountain Lion :

Currently we found that there are some known issues related to using Splashtop Personal(Splashtop 2) on Mountain Lion.  Please check the following descriptions and try the suggested workaround, if your situation is listed below.

If your problem is not listed below, we welcome you to post a description of it here, so we can try to solve it.  Please attach the log files which are generated by the Streamer and the iPad.  These log files are very helpful for debugging purposes.  If you need instructions about obtaining these log files, please see sub-sections "A" and "B" near the end of this topic.

 

1.  The screen on your iPad is messed up after connecting to a computer running the Streamer.

If your Mac is Mountain Lion and in Display sleep mode, your iPad can see it, and the status of the Mac will be shown as "available to be connected to" (colorful).  But the iPad may get a messed-up screen after connecting to that Mac.  In this case, you can do the following as a work-around.

a)  Install our Virtual Driver, then restart your computer and try again.  You can install our Virtual Driver from the Streamer > Settings > Install driver button.

b)  After doing the above, continue by trying the following steps:
      I.  Connect (and then if your iPad has a messed-up screen, proceed to the next step).
      II.  Tap on the iPad to wake up the computer from display sleep.
      III.  Disconnect.
      IV.  Re-connect to get a normal screen.

2.  In our testing, we found that Wake-on-LAN (WoL) does not work on the Mac Book Pro or the Mac mini 2008.  However, it does work on the Mac mini 2010.

In our most recent internal testing, we found that Apple has fixed this in OS X 10.8.1, and Wake-on-LAN works.  Please update your Mountain Lion and try again.  Please also update your Mac Streamer to the latest version (v2.1.0.4 or above), then re-start your computer to get a clean environment.

 

II. For All OS X :

1.   Mac Streamer is not loaded (or 100% CPU usage) when launching it right after the computer starts up, or is awakened from a Sleeping state.

In this case, please try the following suggestions:

a)  Un-install the Streamer, and then re-install, making sure to install Streamer v2.3.0.4 or later.  Then re-start the computer to see if there's any improvement.  If not, please send us your log file.  Instructions for how to send us the Mac Streamer log file (and iPad log file) are in sub-sections "A" and "B" near the end of this topic.

b)  Remove these two files from the  ~Library/preferences folder  (this applies only to the v2.2.x or earlier versions):

•  com.splashtop.Splashtop-Streamer.plist

•  com.splashtop.Splashtop-Streamer-UsageTracking.plist

c)  Go to System Preferences --> Security & Privacy --> Firewall tab --> Click the Firewall Options button, and then delete "Splashtop Streamer" and "SRFeature" if they are there --> Uninstall the Streamer --> install the Streamer again.

d)  If you have installed Google Drive on your Mac, it may cause the Streamer to crash sometimes due to  unknown reasons.  Please install Splashtop Streamer first, then install Google Drive to work around this issue. 

e)  If your computer is a MacBook Pro, try closing the MBP lid (to put it in Sleep mode) and then reopen it.  The icon will light up again and the CPU usage may be down to a normal percentage.

f) Please do NOT change the default installation location of the Streamer.  It MUST be located in the  Applications folder in order to be successfully launched or uninstalled. 

g)  Please confirm that the Computer Name field in the Sharing screen is not empty.  You can find it under System Preferences --> Sharing.  Enter the computer name in the Computer Name field and please do not use any special character or symbol.  Use English letters only, as shown in the example illustration below.  Then run the Streamer again.

 

mac_streamer.png

 

2.   Blank Screen.

a)  The "Switch monitor" function on the tablet/phone (Control Bar) won't be supported when Blank Screen is enabled during a connection session.

b)  If you check (enable) or uncheck (disable) the Blank Screen option during connection, the session might be terminated.  It's best to change your Blank Screen settings only when not connected.

c)  Click here for more details about the limitations of the Blank Screen feature.

 

3.   An  "SRFeature.app" window keeps popping up, asking you if you want to accept connections.

An example of this dialog is illustrated below.  It may pop up the first time after installation if the firewall is ON, and if it does, please select the Allow button.  Under OS X 10.6.x, there might be a chance that this window keeps popping up.  The current work-arounds are:

srfeaure1.png

a)  Go to System Preferences --> Security & Privacy --> Firewall tab --> Click the Firewall Options button, and then delete all the items related to Splashtop Streamer --> Uninstall the Streamer --> install the Streamer again.

srfeaure2.png

b)  If it still keeps popping up, please turn OFF the firewall.

 

4.   No sound, or only very low volume, when connected via iPad or other client devices.

Sometimes the Soundflower audio driver which Splashtop uses may develop unknown problems and cause sound issues on the Client side.  Please try the following steps to see if there is any improvement.

1.  Uninstall the Mac Streamer.

2.  Uninstall Soundflower.

3.  Restart the computer.

4.  Re-install the Mac Streamer.  This will also install Soundflower again automatically.

5.  Restart the computer again.

Please see sections "C" and "D" below, for more detailed steps.

 

A).  How do I get the log file from the Streamer so I can send it to you?

For Mac Streamer v2.3.0.4 or later versions:

1.  On the Mac, open the Terminal application by selecting Application->Utility->Terminal 
2.  Input cp  /Users/Shared/SplashtopStreamer/SPLOG.txt  ~/Desktop 

*   (Note that there is a space prior to the tilde (~) above.
Then you will get the log file (SPLOG.txt) on your Desktop.

 

For Mac Streamer v2.2.x or earlier versions:

1.  On the Mac, open the Terminal application by selecting Application->Utility->Terminal
2.  Input cp  ~/Library/Logs/SPLog.txt  ~/Desktop

*   (Note that there is a space prior to each of the two tildes (~) above.
Then you will get the log file (SPLog.txt) on your Desktop.

 

B).  How do I get the log file from the iPad so I can send it to you?

1.  Update to v2.0.0.6+ on both the iPad app and the Streamer (need Internet connection in order to do this).
2.  Open the app on the iPad, then click the "Settings" icon (it's the "gear" icon in the upper right).
3.  Log out, then append  @@@@@@beta  to the end of your Splashtop Account.
4.  Log in again.  A new tab named "Experimental" will appear on the same page.
5.  Click the "Experimental" tab.  Then click "Send debug information."  Your mail client app will be opened, and a log file "[strc-ioslog]date-xxx_time-xxxx.log" will be attached.
6.  Send it yourself, then attach it here, or on the support ticket.

 

C).  How do I completely un-install the Mac Streamer?

1.  Click "Go" on the Tray menu (upper left) and select Downloads to open the Download folder.
2.  Double-click on the "Splashtop_Streamer_Mac_vx.x.x.x.dmg" file.  (The file name will vary depending on the version downloaded.)
3.  Double-click "Uninstall Splashtop Streamer."
4.  If a warning message appears, click "Open" in the message box.
5.  Input user password to continue the Running if system requests it.
6.  Restart your Mac.
7.  Confirm that the Streamer is removed completely (the Splashtop Streamer icon no longer exists in LaunchPad).

 

D).  How do I un-install Soundflower?

1.  Click "Go" on the Tray menu (upper left).

2.  Click the  "Go to Folders" item.
3.  Type "/System/Library/Extensions"
4.  Find the file "Soundflower.kext"
5.  Remove that file, and then re-start the Mac system.
6.  Open System Preferences -> Sound -> Output.
You should not see SoundFlower anymore in the Output tab.

Have more questions? Submit a request

63 Comments

  • 0
    Avatar
    Jaff.Kuo

    @Tadeáš Němec,

    About black screen with VLC player issue, please check this link for the solution about settings adjustment.

    http://support-splashtop2.splashtop.com/entries/21516912-Why-is-there-only-audio-playback-no-video-when-I-am-watching-a-movie-on-my-tablet-phone-

    For the no sound issue on ipad, please check this link for more info about suggestions.

    http://support-splashtop2.splashtop.com/entries/21531627-why-isn-t-there-any-sound-being-streamed-to-my-tablet-phone

    BTW, so far, we don't get any feedback from users about BT kbd compatibility issue, and we don't have ZAGG BT kbd on hand to have a test, it would be much appreciated if you can share us any info about it.

  • 0
    Avatar
    Tadeáš Němec
    Thanks for the fast reply. Since I wrote my comment I uninstall the splashtop streamer and install it again and I could finally hear the sound. Thanks for advice with VLC player, I'll try it.
  • 0
    Avatar
    Prof. Michael Kleper

    I am unable to install Streamer on my new MacBook Air with the latest version of OS X. It did not complete the installation. I quit the installation and tried to reinstall it, but when I do, it says that it is waiting to complete previous installations. Please let me know what to do.

     

    Michael

  • 0
    Avatar
    Jaff.Kuo

    @Prof. Michael Kleper,

    Have you tried the suggestions on this link? ([Mac streamer] section)

    http://support-splashtop2.splashtop.com/entries/22288646-After-the-Streamer-installer-completed-I-can-t-open-the-Streamer-program-

  • 0
    Avatar
    Delana.Lightfoot

    I have a MacBook Pro running OS 10.8.3 and I just downloaded and installed the splashtop streamer on my mac. Once installed, I also installed the virtual driver under Settings. I can successfully connect to my iPad. My only issue is that I want to use my iPad as a second monitor, but all I can get it to do is mirror my macbook. I have no options to change this under the splashtop settings on my macbook. Any suggestions?

  • 0
    Avatar
    Jackson.Kwan

    Folks .. I am not very please with my new purchase.  I am on a Macbook Air 10.8.3 and installed (and reinstalled) Streamer 2.3.0.4

    It's simply not running after installations.  Any thoughts?  Thx 

  • 0
    Avatar
    Jaff.Kuo

    @Delana.Lightfoot,

    When your computer attaches two monitors, Splashtop 2 app can switch screen between these two monitors.(tap '^' during Splashtop session on lower right)

    If your computer only attaches one monitor and want your ipad to be the extended screen, so far Splashtop XDisplay app can do this feature.

  • 0
    Avatar
    Jaff.Kuo

    @Jackson.Kwan,

    Have you tried uninstall-->restart-->reinstall again?

    If it still doesn't work, please download this v2.2.0.2, install it first, then reinstall v2.3.0.4 to see if helps.

    https://dl.dropboxusercontent.com/u/38993533/Splashtop_Streamer_MAC_v2.2.0.2.dmg

  • 0
    Avatar
    Jackson.Kwan

    Yes sir, about 7 times.  Lemme try what you suggest.

  • 0
    Avatar
    Jackson.Kwan

    Jaff.Kuo - sorry mate, no joy.  Other ideas?

  • 0
    Avatar
    Jaff.Kuo

    @Jackson,

    Could you confirm again you have tried 'f'' and 'g' on this article, section II, item#1?

    (no empty computer name and never change the installed folder of streamer)

    We just updated these two tips yesterday.

  • 0
    Avatar
    Etaibogen

    Hi Jaff, 

    I have the same problem, everything runs very laggy! it starts when i turn on the annotation on a running video, everything starts to lag. every time i draw a new line the video freezes! when i use the whiteboard app. its a bit better but still laggy.

     

    please help....

  • 0
    Avatar
    Jackson.Kwan

    Works like a charm!. Thanks very much!!!

  • 0
    Avatar
    Joe

    My iMac connects but dumps out after about 10 seconds or so.  My windows machines work fine but the iMac with mountain lion dumps.  This is using the pc host.  Haven't tried with my android tablet yet.

  • 0
    Avatar
    Jaff.Kuo

    @Etaibogen,

    If you are talking about Whiteboard feature in Production Pack, our current design is when drawing on ipad, the frame rate will automatically drop to 1 frame per second to help the performance on ipad side. It's much different from another Splashtop Whiteboard app(gen1 app).

    But the performance will recover back when you finish your drawing. If you don't draw anything with Whiteboard tool but still get slower performance, maybe your computer CPU/display or available bandwidth is not so good. Check this link for some suggestions about streaming performance.

    https://support-splashtop2.splashtop.com/entries/21523003-How-can-I-get-the-best-performance-from-using-Splashtop-2-

  • 0
    Avatar
    Jaff.Kuo

    @Joe,

    Could you try uninstall mac streamer by the following steps and reinstall again?

    (1). D-click "Splashtop_Streamer_Mac_v2.3.0.4.dmg".
    (2). D-click "Uninstall Splashtop Streamer".
    (3). Click "Run" to uninstall Splashtop Remote
    (4). Input user password to continue the Running if system requests you.
    (5). Restart your Mac
    (6). Confirm Streamer is removed completely (no more Splashtop Streamer icon exists in LaunchPad).

    (7). reinstall again by d-click Splashtop Streamer.pkg

    (8). re-configure streamer(login Splashtop account...), restart mac

    Please also update the latest win client v2.3.0.2 from our website(http://www.splashtop.com/streamer/downloadstart?platform=windows-client), and try again.

    (or v2.3.0.7 for android from google play, or win streamer v2.3.0.2 from our website)

  • 0
    Avatar
    Iwlyafm

    For the streamer, I have some problem with it. I cannot connect my laptop with it even I tried to restart and reinstall for so many times. Do you have any idea what should I do to make it work? 

  • 0
    Avatar
    Jaff.Kuo

    @Iwlyafm,

    Could you share us what error you got?

    Please also disable "Require security code" on Streamer/Security tab if it's enabled.

  • 0
    Avatar
    Paul

    I'm having the same problem trying to connect to my iMac from my MacBook Air using the Splashtop 2 Client (both running 10.8.4) if "Require security code" is enabled.  I don't have any problems connecting from my iPhone or iPad.

    When i try to connect, I get a dialog box that says "Enter the password for your Splashtop Account" which is odd since I've already entered that, but whether I enter my Splashtop Account password or the security code I set in the streamer on my iMac, it tells me "Wrong password. Could not connect."

    I've tried everything and the only thing that works is disabling "Require security code".  But I don't want to leave it insecure.

  • 0
    Avatar
    Jaff.Kuo

    @Paul,

    This is a known issue on Mac client v2.0.2, we'll fix it in next update.

    Please disable "Require security code" as a work around at this moment. Sorry for this inconvenience.

  • 0
    Avatar
    Fantasiaf

    since the last update your desktop program keeps randomly closing on my Mac while I am connected with my ipad

  • 0
    Avatar
    Jaff.Kuo

    @Fantasiaf,

    It's a known issue on v2.3.0.8, we'll try to fix it.

    Please use this old version as the work around if it's too annoying.

    https://dl.dropboxusercontent.com/u/38993533/Splashtop_Streamer_MAC_v2.2.0.2.dmg

  • 0
    Avatar
    Office

    @Kuo

    That is more than annoying. The app is unusable at this point; the link you provided points to a version that won't even start on my mac 10.8.4.

    I am not amused!

  • 0
    Avatar
    Office

    P.S.: v2.3.0.9, which I am using, has not resolved that issue.

  • 0
    Avatar
    Fantasiaf

    I uninstalled Splashtop from my Mac and installed the rollback version from Kuo's link and haven't had a problem with it since.  Thanks Kuo.

  • 0
    Avatar
    Office

    More quirx:

    Installed streamer v2.3.0.9 on 3 machines: "server01" (IP: xxx.xxx.xxx.129), "server02" (IP: xxx.xxx.xxx.130), "server03" (IP: xxx.xxx.xxx.131).

    On my iPad-listing after a few minutes I get 2 versions of "server 02"; one with the correct IP; the other with the actual IP of "server03"; none of them working; "server01" is missing at all. After a refresh the listed names change randomly; CPU-load on the machines running streamer at 40%! 

    What a mess!

  • 0
    Avatar
    Icpmjrat25
    Hello I was having the random shut down issue so reinstalled the former version but now my mac cpu runs at 100% Funny this is, I ran version 1 for a year or so, it did everything I wanted and didn't have a problem. Can't we just go back to that?
  • 0
    Avatar
    Ladave75

    Does the 2.3.0.9 version have a connectivity bug?  I was using the 2.2.0.2 version without any issues, and then I upgraded to 2.3.0.9 and couldn't connect remotely to my Mac anymore.  I un-installed 2.3.0.9 and re-installed 2.2.0.2 and it works fine again.   Any ETA on fixing the issue in the latest version of streamer?

  • 0
    Avatar
    Office

    Gave it another try with Streamer v2.4.0.3 on a MacMini Core2Duo. Streamer-app using 100% CPU on the MacMini when connected; on the connected iPad the Sound is distorted fuzz. EyeTV SW on the Mini repeatedly comes up with "No Signal" message, has to be quit and restarted (never happens when Streamer is NOT running!)

     

    Your SW turns out after a few weeks to be a dangerous, completely mess; want my money back!!!!

  • 0
    Avatar
    Bsefting

    I am running Streamer 2.3.0.9 on my MBP with 2.4GHz Core 2 Duo and Mac OSX 10.8.4.

    I was noticing that the streamer was crashing at random so I wrote up a quick shell script that checks for the process and restarts it if it's missing.

    The output of the streamer was then going to a logfile and captured some different info than what shows in the SPLOG.

    Here is what shows in the SPLOG during a crash:

    2013-08-13 14:38:06.705 [2][CLO][0:63259] successful for command 0, subType 0
    2013-08-13 14:38:21.498 [2][DAE][0:63259] drop connection from /tmp/com.splashtop.Splashtop Streamer_501/socket [501]
    2013-08-13 14:38:21.498 [2][DAE][0:63259] Suspending product line
    2013-08-13 14:38:21.498 [2][___][0:63259] ipc send error: 32
    2013-08-13 14:38:21.528 [2][DAE][0:63259] no user checked in now
    2013-08-13 14:38:21.528 [2][DAE][0:63259] ------ tracking suspend
    2013-08-13 14:38:21.529 [2][DAE][0:63259] ret : 0 cpret :1
    2013-08-13 14:38:21.529 [2][DAE][0:63259] drop connection from /tmp/com.splashtop.Splashtop Streamer_501/socket [501]
    2013-08-13 14:38:21.529 [2][DAE][0:63259] produce hasn't been started
    2013-08-13 14:38:21.529 [2][DAE][0:63259] no user checked in now
    2013-08-13 14:38:21.529 [2][DAE][0:63259] ------ tracking suspend
    2013-08-13 14:38:21.529 [2][DAE][0:63259] ret : 0 cpret :1

     

    Here is what I saw in the output from the streamer:

    x264 [info]: frame I:1 Avg QP:24.01 size:167786
    x264 [info]: frame P:58526 Avg QP:16.65 size: 12360
    x264 [info]: mb I I16..4: 41.2% 26.3% 32.5%
    x264 [info]: mb P I16..4: 0.5% 0.3% 0.1% P16..4: 9.6% 0.0% 0.0% 0.0% 0.0% skip:89.5%
    x264 [info]: 8x8 transform intra:30.7% inter:20.2%
    x264 [info]: coded y,uvDC,uvAC intra: 51.0% 50.0% 38.2% inter: 6.1% 2.7% 0.4%
    x264 [info]: i16 v,h,dc,p: 79% 9% 11% 1%
    x264 [info]: i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 11% 19% 35% 3% 9% 5% 7% 4% 9%
    x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 13% 31% 30% 2% 7% 3% 5% 2% 7%
    x264 [info]: i8c dc,h,v,p: 59% 19% 17% 4%
    x264 [info]: kb/s:2967.45
    x264 [error]: invalid width x height (0x0)
    2013-08-13 14:38:20.150 Splashtop Streamer[63958:11407] -[NSConcreteValue userInfo]: unrecognized selector sent to instance 0x1048ecb40
    2013-08-13 14:38:20.151 Splashtop Streamer[63958:11407] An uncaught exception was raised
    2013-08-13 14:38:20.152 Splashtop Streamer[63958:11407] -[NSConcreteValue userInfo]: unrecognized selector sent to instance 0x1048ecb40
    2013-08-13 14:38:20.206 Splashtop Streamer[63958:11407] (
    0 CoreFoundation 0x00007fff87e77b06 __exceptionPreprocess + 198
    1 libobjc.A.dylib 0x00007fff8d34d3f0 objc_exception_throw + 43
    2 CoreFoundation 0x00007fff87f0e40a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
    3 CoreFoundation 0x00007fff87e6602e ___forwarding___ + 414
    4 CoreFoundation 0x00007fff87e65e18 _CF_forwarding_prep_0 + 232
    5 Splashtop Streamer 0x0000000100008787 -[SRx264VideoEncoder jobSchedule] + 587
    6 Splashtop Streamer 0x0000000100036fd3 -[SRThread workProcedure:] + 309
    7 Foundation 0x00007fff85615562 __NSThread__main__ + 1345
    8 libsystem_c.dylib 0x00007fff8f9077a2 _pthread_start + 327
    9 libsystem_c.dylib 0x00007fff8f8f41e1 thread_start + 13
    )
    2013-08-13 14:38:20.215 Splashtop Streamer[63958:11407] *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSConcreteValue userInfo]: unrecognized selector sent to instance 0x1048ecb40'
    *** First throw call stack:
    (
    0 CoreFoundation 0x00007fff87e77b06 __exceptionPreprocess + 198
    1 libobjc.A.dylib 0x00007fff8d34d3f0 objc_exception_throw + 43
    2 CoreFoundation 0x00007fff87f0e40a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
    3 CoreFoundation 0x00007fff87e6602e ___forwarding___ + 414
    4 CoreFoundation 0x00007fff87e65e18 _CF_forwarding_prep_0 + 232
    5 Splashtop Streamer 0x0000000100008787 -[SRx264VideoEncoder jobSchedule] + 587
    6 Splashtop Streamer 0x0000000100036fd3 -[SRThread workProcedure:] + 309
    7 Foundation 0x00007fff85615562 __NSThread__main__ + 1345
    8 libsystem_c.dylib 0x00007fff8f9077a2 _pthread_start + 327
    9 libsystem_c.dylib 0x00007fff8f8f41e1 thread_start + 13
    )
    libc++abi.dylib: terminate called throwing an exception

     

    Hopefully this will be useful to your devs...

Please sign in to leave a comment.