Some known issues on Mac Streamer, and work-arounds

I. For Mountain Lion :

Currently we found that there are some known issues related to using Splashtop 2 on Mountain Lion.  Please check the following descriptions and try the suggested workaround, if your situation is listed below.

If your problem is not listed below, we welcome you to post a description of it here, so we can try to solve it.  Please attach the log files which are generated by the Streamer and the iPad.  These log files are very helpful for debugging purposes.  If you need instructions about obtaining these log files, please see sub-sections "A" and "B" near the end of this topic.

 

1.  The screen on your iPad is messed up after connecting to a computer running the Streamer.

If your Mac is Mountain Lion and in Display sleep mode, your iPad can see it, and the status of the Mac will be shown as "available to be connected to" (colorful).  But the iPad may get a messed-up screen after connecting to that Mac.  In this case, you can do the following as a work-around.

a)  Install our Virtual Driver, then restart your computer and try again.  You can install our Virtual Driver from the Streamer > Settings > Install driver button.

b)  After doing the above, continue by trying the following steps:
      I.  Connect (and then if your iPad has a messed-up screen, proceed to the next step).
      II.  Tap on the iPad to wake up the computer from display sleep.
      III.  Disconnect.
      IV.  Re-connect to get a normal screen.

2.  In our testing, we found that Wake-on-LAN (WoL) does not work on the Mac Book Pro or the Mac mini 2008.  However, it does work on the Mac mini 2010.

In our most recent internal testing, we found that Apple has fixed this in OS X 10.8.1, and Wake-on-LAN works.  Please update your Mountain Lion and try again.  Please also update your Mac Streamer to the latest version (v2.1.0.4 or above), then re-start your computer to get a clean environment.

 

II. For All OS X :

1.   Mac Streamer is not loaded (or 100% CPU usage) when launching it right after the computer starts up, or is awakened from a Sleeping state.

In this case, please try the following suggestions:

a)  Un-install the Streamer, and then re-install, making sure to install Streamer v2.3.0.4 or later.  Then re-start the computer to see if there's any improvement.  If not, please send us your log file.  Instructions for how to send us the Mac Streamer log file (and iPad log file) are in sub-sections "A" and "B" near the end of this topic.

b)  Remove these two files from the  ~Library/preferences folder  (this applies only to the v2.2.x or earlier versions):

•  com.splashtop.Splashtop-Streamer.plist

•  com.splashtop.Splashtop-Streamer-UsageTracking.plist

c)  Go to System Preferences --> Security & Privacy --> Firewall tab --> Click the Firewall Options button, and then delete "Splashtop Streamer" and "SRFeature" if they are there --> Uninstall the Streamer --> install the Streamer again.

d)  If you have installed Google Drive on your Mac, it may cause the Streamer to crash sometimes due to  unknown reasons.  Please install Splashtop Streamer first, then install Google Drive to work around this issue. 

e)  If your computer is a MacBook Pro, try closing the MBP lid (to put it in Sleep mode) and then reopen it.  The icon will light up again and the CPU usage may be down to a normal percentage.

f) Please do NOT change the default installation location of the Streamer.  It MUST be located in the  Applications folder in order to be successfully launched or uninstalled. 

g)  Please confirm that the Computer Name field in the Sharing screen is not empty.  You can find it under System Preferences --> Sharing.  Enter the computer name in the Computer Name field and please do not use any special character or symbol.  Use English letters only, as shown in the example illustration below.  Then run the Streamer again.

 

mac_streamer.png

 

2.   Blank Screen.

a)  The "Switch monitor" function on the tablet/phone (Control Bar) won't be supported when Blank Screen is enabled during a connection session.

b)  If you check (enable) or uncheck (disable) the Blank Screen option during connection, the session might be terminated.  It's best to change your Blank Screen settings only when not connected.

c)  Click here for more details about the limitations of the Blank Screen feature.

 

3.   An  "SRFeature.app" window keeps popping up, asking you if you want to accept connections.

An example of this dialog is illustrated below.  It may pop up the first time after installation if the firewall is ON, and if it does, please select the Allow button.  Under OS X 10.6.x, there might be a chance that this window keeps popping up.  The current work-arounds are:

srfeaure1.png

a)  Go to System Preferences --> Security & Privacy --> Firewall tab --> Click the Firewall Options button, and then delete all the items related to Splashtop Streamer --> Uninstall the Streamer --> install the Streamer again.

srfeaure2.png

b)  If it still keeps popping up, please turn OFF the firewall.

 

4.   No sound, or only very low volume, when connected via iPad or other client devices.

Sometimes the Soundflower audio driver which Splashtop uses may develop unknown problems and cause sound issues on the Client side.  Please try the following steps to see if there is any improvement.

1.  Uninstall the Mac Streamer.

2.  Uninstall Soundflower.

3.  Restart the computer.

4.  Re-install the Mac Streamer.  This will also install Soundflower again automatically.

5.  Restart the computer again.

Please see sections "C" and "D" below, for more detailed steps.

 

A).  How do I get the log file from the Streamer so I can send it to you?

For Mac Streamer v2.3.0.4 or later versions:

1.  On the Mac, open the Terminal application by selecting Application->Utility->Terminal 
2.  Input cp  /Users/Shared/SplashtopStreamer/SPLOG.txt  ~/Desktop 

*   (Note that there is a space prior to the tilde (~) above.
Then you will get the log file (SPLOG.txt) on your Desktop.

 

For Mac Streamer v2.2.x or earlier versions:

1.  On the Mac, open the Terminal application by selecting Application->Utility->Terminal
2.  Input cp  ~/Library/Logs/SPLog.txt  ~/Desktop

*   (Note that there is a space prior to each of the two tildes (~) above.
Then you will get the log file (SPLog.txt) on your Desktop.

 

B).  How do I get the log file from the iPad so I can send it to you?

1.  Update to v2.0.0.6+ on both the iPad app and the Streamer (need Internet connection in order to do this).
2.  Open the app on the iPad, then click the "Settings" icon (it's the "gear" icon in the upper right).
3.  Log out, then append  @@@@@@beta  to the end of your Splashtop Account.
4.  Log in again.  A new tab named "Experimental" will appear on the same page.
5.  Click the "Experimental" tab.  Then click "Send debug information."  Your mail client app will be opened, and a log file "[strc-ioslog]date-xxx_time-xxxx.log" will be attached.
6.  Send it yourself, then attach it here, or on the support ticket.

 

C).  How do I completely un-install the Mac Streamer?

1.  Click "Go" on the Tray menu (upper left) and select Downloads to open the Download folder.
2.  Double-click on the "Splashtop_Streamer_Mac_vx.x.x.x.dmg" file.  (The file name will vary depending on the version downloaded.)
3.  Double-click "Uninstall Splashtop Streamer."
4.  If a warning message appears, click "Open" in the message box.
5.  Input user password to continue the Running if system requests it.
6.  Restart your Mac.
7.  Confirm that the Streamer is removed completely (the Splashtop Streamer icon no longer exists in LaunchPad).

 

D).  How do I un-install Soundflower?

1.  Click "Go" on the Tray menu (upper left).

2.  Click the  "Go to Folders" item.
3.  Type "/System/Library/Extensions"
4.  Find the file "Soundflower.kext"
5.  Remove that file, and then re-start the Mac system.
6.  Open System Preferences -> Sound -> Output.
You should not see SoundFlower anymore in the Output tab.

Have more questions? Submit a request

62 Comments

  • 0
    Avatar
    Genghis.2011

    I followed the recommendation of your "BTW" paragraph - Soundflower DID NOT install during the installation of Streamer 2.  What do you suggest?

  • 0
    Avatar
    Jaff.Kuo

    @Genghis Kahn,

    Please uninstall Splashtop Streamer then re-install, it'll automatically install Soundflower driver.

    Please note that if there's a message box ask you to input your admin ID/Passowrd, please agree to proceed, it's to confirm you agree to install it. (see attachment for that box)




    no_soundflow.png
  • 0
    Avatar
    Genghis.2011

    I have followed your guidance exactingly.  The complete reinstallation resulted in the same original behavior.  During Mountain Lion account log on, the Splashtop 2 Streamer icon displays, pinwheel overlays the icon, streamer unloads.  Soundflower is installed.  

  • 0
    Avatar
    Phinnysquanto
    so i have a fesh install (formated drive first) of mtn lion on a 2007 iMac and it to fails to work on the WOL for any WAN connection. the LAN sort of works, but the screen is all fuzzy and i had to install the xdisplay drivers. Logmein worked fine from LAN or WAN.
  • 0
    Avatar
    Genghis.2011

    FYI

     

    I have followed every suggestion exactingly.  Streamer DOES NOT load correctly upon user account log on.  As stated previously, Open is requested, icon appears in Menu Bar briefly during which time placing the OS X Mountain Lion cursor on the icon results in the Pin Wheel busy icon.  Pin Wheel disappears along with the Streamer icon.  My iMac 24SD is no longer visible to Splashtop Remote Desktop on any of my other computer systems.

    Additional observations:

    1.  After cold booting or restarting my iMac 24SD and the user log on screen appears, this iMac IS VISIBLE to Splashtop Remote Desktop from ALL of my computer systems.

    2.  However, upon attempting to log on to the iMac from any system results in the diagnostic that Remote cannot connect to the iMac.

    3.  Any subsequent attempt to log on to the iMac results in the diagnostic that the iMac is already connected to "another Splashtop session."

    4.  The iMac which was originally displaying its user log on screen has gone blank with no log on dialogue and no way to access or operate the system.

    5.  The iMac must be power cycled to restore the user account log on screen.

    It is clear to me that there are serious issues running Splashtop Streamer 2 on OS X Mountain Lion.  It may be related to the enhanced security options of Mountain Lion.

    I am a technology consultant.  The services I render tend toward resolving the "hopeless"  issues for my clients.  I operate from the premise that a solution is possible.  However, I cannot resolve issues when the problem resides in the tight and inaccessible integration of a program with the underlying operating system.  This is where users like myself MUST rely on the tech geniuses at Splashtop to be taking seriously issues such as mine.  In perusing the net, it is clear to me that this Mountain Lion issue with Splashtop Streamer is being experienced by an increasing number of users.

  • 0
    Avatar
    Jaff.Kuo

    Hi all,

    We internal also found a similar issue with the one you got on Mountain Lion, and is working on fixing it, please wait for our next update.

     

    @Phinnysquanto,

    WoL for WAN is still not supported for Splashtop 2, it only supports connected via Ethernet at this moment.

  • 0
    Avatar
    Jeremy

    @Jaff-Splashtop,

     

    Do we have an estimated release date for the update? A ball-park figure even? I'm going to be traveling soon and am going to be depending on this product to keep me connected.

  • 0
    Avatar
    Genghis.2011

    I just installed Streamer 2.1.0.3 for Mac.  Streamer continues to fail to load correctly in OS X Mountain Lion.

  • 0
    Avatar
    Genghis.2011

    I STAND CORRECTED.  VERSION 2.1.0.3 is now working under OS X Mountain Lion.

    Thank you for rectifying this issue!

  • 0
    Avatar
    Predrag Chemerikikj

    Even Ver. 2.1.0.4 DOES NOT work !  The streamer starts loading (grayed) and ... NOTHING. Uninstalled, rebooted, Installed etc - NOPE

  • 0
    Avatar
    Christian Korte

    I am still having the same issue with the loading pinwheel on 2.1.0.4. If there is a fix or new version could you please notify me by email?

  • 0
    Avatar
    Michael kruger
    I have the latest mountain lion version plus the latest splashtop 2, my problem is that pretty much each time I try to connect to the mac the icon is greyed out on the iPad but the mac is on.to get to work I have to log out of streamer then log back in on the mac, I can then connect from the iPad for a few hours . Pe Pretty frustrating is this issue being looked at? Thanks Mike
  • 0
    Avatar
    Tommy

    I have a mac book pro and can not see the icons of the login screen when try to connect to my mac book pro retina display (running streamer 2.1.0.4) via my non retina display mac book (using remote 1.3.4).  I just see a blank gray screen.  I have to physically login to my mac book pro retina display to be able to see anything.

  • 0
    Avatar
    Jaff.Kuo

    Hi all,

    For the issue mac streamer can't be successfully loaded, please try these two suggestions as follows.

    a)  Uninstall the Streamer and then re-install, Streamer v2.1.0.4 or above.  Then re-start the computer to see if there's any difference.  If not, please send us your log file (instructions are at the end of this topic).

    b)  If your computer is a MacBook Pro, try closing the MBP lid (to put it in Sleep mode) and then reopen it.  The icon will light up again and the streamer and CPU usage may be down to a normal state.

    Some of your cases may be still there, we are working on other better solutions. Please stay tuned.

  • 0
    Avatar
    Predrag Chemerikikj

    <1>Oct 1 20:05:45 [SRFeatur]:[Core] SRFeature Start
    <1>Oct 1 20:05:45 [SRFeatur]:[Core] server version : 2.1.0.4
    <1>Oct 1 20:05:45 [SRFeatur]:[Core] server feat opt : 0xFF2005FE
    <1>Oct 1 20:05:45 [SRFeatur]:[Core] server feat must: 0x00000003
    <0>Oct 1 20:05:45 [SRFeatur]:[Core] UdpMode key is not exist
    <1>Oct 1 20:05:45 [SRFeatur]:[Core] Udp Broadcast setting: 0x00000002
    <1>Oct 1 20:05:45 [SRFeatur]:[Cloud] GetMACAddress OK
    <1>Oct 1 20:05:45 [SRFeatur]:[Cloud] Using Cloud version: 0x00020000 => v2

     

     

    Still grey ....

  • 0
    Avatar
    P Gruver
    I was unable to download Streamer on my Mac. I tried this 4 times last night. Each time it worked on it for some time (as much as twenty min.) but always failed to complete. Each time it stopped at varying degrees of completion. The only message that I got was that it failed to complete. This morning I tried it and it downloaded in less than a minute? I'll see if it will run today.
  • 0
    Avatar
    David Campbell

    SRFeature kills my CPU. As soon as i connect to my host computer the cpu usage of SRFeature skyrockets to between 150- 360%. The computer runs hot after a very short while. I'm not able to connect to the computer like this, it will overheat. What I've tried:

    1. Different screen resolutions
    2. Connecting from another computer and also from an android device 
    3. installing the display driver from splashtop streamer settings on host computer 
    4. shutting of the built in remote desktop feature on my mac (remote login in sharing settings)
    5. deactivated my firewall on the host computer
    6. installing soundflower as a separate package from the soundflower homepage just in case 

     And of course i have restarted the computer several times between every tested setting - no difference.

  • 0
    Avatar
    Tae Kim

    I followed everything you mentioned about the issues, and installed new version of streamer,, but still not working on mountain lion.

  • 0
    Avatar
    Jaff.Kuo

    Not sure if this new tip helpful to your case.

    b)  Remove these two files from the  ~Library/preferences folder.

    •  com.splashtop.Splashtop-Streamer.plist

    •  com.splashtop.Splashtop-Streamer-UsageTracking.plist

  • 0
    Avatar
    hcg2008

    Can't start in mountain lion 10.8.2.

    Process: SRFeature [1116]
    Path: /Applications/Splashtop Streamer.app/Contents/MacOS/SRFeature.app/Contents/MacOS/SRFeature
    Identifier: com.splashtop.SRFeature
    Version: 2.1.0.6 (2.1.0.6)
    Code Type: X86-64 (Native)
    Parent Process: Splashtop Streamer [1114]
    User ID: 501

    Date/Time: 2012-10-20 13:36:39.569 +0800
    OS Version: Mac OS X 10.8.2 (12C60)
    Report Version: 10

    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

     

    SHORTEN IT TO INCREASE READABILITY 

  • 0
    Avatar
    Dan Suleiman

    hcg2008 - thats some serious thread crapping you got on there

  • 0
    Avatar
    Dan Suleiman

    Splashtop2 causes my Mac mini 2011 to run all 4 cores at 100% meaning the fan is very loud trying to cool them - which it just manages to keep under 100 degC.

    This obviously makes the app unusable for me - tried the suggestions at the top of the thread, makes no difference. All is well when it's idle but as soon as I view the desktop from another machine, the mac starts to cook.

    Are you guys still working on this, or should I just un-install and leave bad feedback in the app store?

  • 0
    Avatar
    Jaff.Kuo

    Hi all,

    Sorry for this annoying issue.

    Our engineering is working hard for solving it with a code re-structure, however, it'll consume much efforts and need longer time. Please give us more time to polish it internally.

    Thanks for your patience.

  • 0
    Avatar
    Teplitxky Adrien
    I bought Slashtop for ipad yesterday, after what I and installed Slashtop streamer on my Mac mini running OS 10.8, and the virtual driver. Rebooted my mac... and got a hang up on reboot (gray screen, wheel spinning). Had to reboot in safe mode. The Mac got so slow I eventually finished uninstalling splashtop. A very frustrating experience... When do you plan to release a working version?
  • 0
    Avatar
    Stephen R Saklad, PharmD, BCPP

    It is now 2013. Do you have any expected date when the high CPU problem will be corrected?

  • 0
    Avatar
    AG

    I have a question about the Splashtop Preferences Window.  I am running ML on a Mac Pro and MacBook  Pro and it worked when I first installed it on my computers.  But now I want to change one of the settings in the Splashtop Preferences Window, but I have only seen this window once and only on one of the two computers during installation and cannot figure out how to open it again.

    I have tried erasing the files and rebooting the computers as indicated on other threads for different issues hoping it may help in this case.

    Any help would be greatly apprecaited.

  • 0
    Avatar
    AG

    Sorry for the question, I just noticed that there is a menubar icon which allows me to access the preference pane.  My apologies.

  • 0
    Avatar
    Grace Eunbi Kim

    Hi, i tried everything to run the streamer on my mountain lion 10.8 but it seems not working. I used all methods Jeff posted here and there like using beta, uninstall-reinstalling, and deleting some files. NONE OF THESE worked for me and i'm tired of dealing with this.

    Is there anyway I can get refund for my app purchase on my ipad? i bought the app on my ipad first and then tried to install the streamer on my mac so I'd like to get refund. 

  • 0
    Avatar
    Jaff.Kuo

    @Grace Eunbi Kim & all,

    Our engineering is actively working on fixing this annoying issue, it's a complicated re-architecture case, and already in a beta stage now. We'll release a new beta again soon and ask for all your try.

    If you still feel strongly to get a refund, please submit a support ticket to let our support staff help you.

    Sorry again and thanks for your patience.

  • 0
    Avatar
    Tadeáš Němec
    I have got some issues with video and audio streaming. First the VLC player shows me some warnings, that I don't have some opengl and I can only see black screen while playing my media. I have also problems with audio streaming, my Mac mini running on Mountain Lion can play audio via the headphones output, but my iPad doesn't make any sound. Would you please clearly tell me, what I should do? thanks...
Please sign in to leave a comment.